pm2 error

From Christian Ogbonna, 1 Week ago, written in Plain Text, viewed 3 times.
URL https://pastebin.freepbx.org/view/f99231e9 Embed
Download Paste or View Raw
  1. [root@amrepbx ~]# fwconsole ma install pm2
  2. Installing/Updating Required Libraries. This may take a while...The following messages are ONLY FOR DEBUGGING. Ignore anything that says 'WARN' or is just a warning
  3. Found npm-cache v0.7.0
  4. Running installation..
  5. [npm-cache] [INFO] using /home/asterisk/.package_cache as cache directory
  6. [npm-cache] [INFO] [composer] Dependency config file /var/www/html/admin/modules/pm2/node/composer.json does not exist. Skipping install
  7. [npm-cache] [INFO] [npm] config file exists
  8. [npm-cache] [INFO] [npm] cli exists
  9. [npm-cache] [INFO] [npm] hash of /var/www/html/admin/modules/pm2/node/package.json: fa2348032788d5067b56972347177c79
  10. [npm-cache] [INFO] [npm] running [npm install]...
  11. npm ERR! not a package /tmp/npm-6832-956e9324/mirror1.freepbx.org/npm/pm2-2.10.6.tgz
  12. npm ERR! Linux 2.6.32-642.6.2.el6.x86_64
  13. npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
  14. npm ERR! node v0.12.18
  15. npm ERR! npm  v2.15.11
  16. npm ERR! path /tmp/npm-6832-956e9324/unpack-a37fdb85c86c/package.json
  17. npm ERR! code ENOENT
  18. npm ERR! errno -2
  19.  
  20. npm ERR! enoent ENOENT, open '/tmp/npm-6832-956e9324/unpack-a37fdb85c86c/package.json'
  21. npm ERR! enoent This is most likely not a problem with npm itself
  22. npm ERR! enoent and is related to npm not being able to find a file.
  23. npm ERR! enoent
  24.  
  25. npm ERR! Please include the following file with any support request:
  26. npm ERR!     /var/www/html/admin/modules/pm2/node/npm-debug.log
  27. [npm-cache] [ERROR] [npm] error running npm install
  28. [npm-cache] [ERROR] error installing dependencies
  29.  
  30. Finished updating libraries!
  31.  
  32. There was an error installing. Please review the install log. (/var/www/html/admin/modules/pm2/node/logs/install.log)
  33. Unable to install module pm2:
  34.  - Failed to run installation scripts
  35. Updating Hooks...Done
  36.  

Reply to "pm2 error"

Here you can reply to the paste above